`backend': no such file to load -- i18n/backend (MissingSourceFile)

Thursday, 07 October 2010

While upgrading an old Rails 2.3.5 app to Rails 2.3.9 I came across this error:

`backend': no such file to load -- i18n/backend (MissingSourceFile)

It’s very simple to fix as Rails 2.3.9 is just missing the i18n dependancy. If you are requiring gems using the old school way just add it to your environment.rb:

config.gem "i18n"

Or if you’re running Bundler, like everyone should be, just add it to your Gemfile and run bundle update:

gem 'i18n'
blog comments powered by Disqus